将oracle11g的表导出并导入到10g中_MySQL, Oracle及数据库讨论区_Weblogic技术|Tuxedo技术|中间件技术|Oracle论坛|JAVA论坛|Linux/Unix技术|hadoop论坛_联动北方技术论坛  
网站首页 | 关于我们 | 服务中心 | 经验交流 | 公司荣誉 | 成功案例 | 合作伙伴 | 联系我们 |
联动北方-国内领先的云技术服务提供商
»  游客             当前位置:  论坛首页 »  自由讨论区 »  MySQL, Oracle及数据库讨论区 »
总帖数
2
每页帖数
101/1页1
返回列表
0
发起投票  发起投票 发新帖子
查看: 986 | 回复: 1   主题: 将oracle11g的表导出并导入到10g中        下一篇 
white
注册用户
等级:少校
经验:1327
发帖:305
精华:0
注册:2011-7-21
状态:离线
发送短消息息给white 加好友    发送短消息息给white 发消息
发表于: IP:您无权察看 2015-8-21 10:24:08 | [全部帖] [楼主帖] 楼主

由于oracle版本问题,11g默认导出的表将无法导入到10g中

会报如下错误:

Connected to: Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - 64bit Production

With the Partitioning, OLAP and Data Mining options

ORA-39001: invalid argument value

ORA-39000: bad dump file specification

ORA-39142: incompatible version number 3.1 in dump file "/oracle/product/10.2.0/rdbms/log/accmonthtrace.dmp"

利用version参数可将11g的表导出并导入到10g中:

从11g导出:

expdp account directory=data_pump_dir dumpfile=accmonthtrace.dmp logfile=accmonthtracetmp.log

tables=accmonthtrace version=10.2.0.1.0

从10g导入:

impdp account directory=data_pump_dir dumpfile=accmonthtrace.dmp logfile=accmonthtracetmp.log

table_exists_action=replace

--转自 北京联动北方科技有限公司




赞(0)    操作        顶端 
联动大白
注册用户
等级:列兵
经验:91
发帖:0
精华:0
注册:2015-5-27
状态:离线
发送短消息息给联动大白 加好友    发送短消息息给联动大白 发消息
发表于: IP:您无权察看 2019-7-20 0:30:00 | [全部帖] [楼主帖] 2  楼

为了方便大家阅读,我对文章中错误号来解释一下吧!

Error Id: ORA-39000

Title: bad dump file specification

Description:

bad dump file specification

Action:

Specify a dump file that is usable for the job.

Cause:

The user specified a dump file that could not be used in the current job. Subsequent error messages describe the inadequacies of the dump file.


Error Id: ORA-39001

Title: invalid argument value

Description:

invalid argument value

Action:

Correct the bad argument and retry the API.

Cause:

The user specified API parameters were of the wrong type or value range. Subsequent messages supplied by DBMS_DATAPUMP.GET_STATUS will further describe the error.


Error Id: ORA-39142

Title: incompatible version number string in dump file "string"

Description:

incompatible version number string in dump file "string"

Action:

Import this dump file using the Data Pump import utility with the same version as the export which created the file.

Cause:

A dump file was specified for an import operation whose version number is incompatible with the dump file version of the Data Pump product currently running on the system. Usually this message indicates that the dump file was produced by a newer version of the Data Pump export utility.


也许你已明白,但对一个人有用也是我存在的理由!^_^ By:持之以恒的大白

-- 来自: 北京联动北方科技有限公司



赞(0)    操作        顶端 
总帖数
2
每页帖数
101/1页1
返回列表
发新帖子
请输入验证码: 点击刷新验证码
您需要登录后才可以回帖 登录 | 注册
技术讨论